
Quickstart Guide xDB -1-200

Prerequisites:

- IFM control / display control

- CODESYS 3.5 with necessary packages

- DATA PANEL xtremeDB (DP-34044-1-200) module + accessories

- DC 12 / 24 V supply



2

Prepare CODESYS

Depending on the type of controller you are working with, the corresponding packages must 
be installed in CODESYS. 

▪ Open CODESYS 

▪ In the taskbar at the top via "Tools -> Package Manager... " open the package manager

▪ Right click on "Install..." and install the corresponding package

▪ In the following example the integration of an ifm display control is described

▪ Double-click or "Open" to install the package (this may take a moment)

▪ If the installation was successful, a corresponding message appears

Creator: BD / Version: 1.54

CODESYS PREPARE

The packages for the respective controller are supplied or you can obtain them from 
the manufacturer's website or the CODESYS Store. A login may be required for the 
download.
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Install EDS device file

▪ Open the device repository via "Tools->Device Repository" in the taskbar at the top.

▪ A new device can be installed via the "Install..." button

▪ Double click on the desired file, alternatively select and open the *. eds file manually . 
The device appears in the list of added devices

Creator: BD / Version: 1.54

CODESYS PREPARE

The permalink below always leads to the latest firmware and *. eds file:
https://drive.google.com/file/d/13cXGUYYZOG3lUt_rOJ86NG2fMGVgUtkJ/view

https://drive.google.com/file/d/13cXGUYYZOG3lUt_rOJ86NG2fMGVgUtkJ/view
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CODESYS project

▪ Open CODESYS

▪ Create a new project via File -> New 
project

▪ Select the corresponding control via 
the library and confirm with OK. The 
action may take some time.

Creator: BD / Version: 1.54

CODESYS PREPARE

CAN communication

▪ Open the "Communication" node and right-click on "CAN -> Attach device".

▪ Select "ifm" as manufacturer and append the "ifmCANbus

▪ Close this window

The controller must be CANopen capable. If you want to work with SAE J1939, you can 
find a CODESYS function block for our modules under the following links:
V2.3: https://www.data-panel.eu/media/archive/CODESYS-23-Demo-DP-34044-x-000.zip
V3.5: https://www.data-panel.eu/media/archive/CODESYS-35-Demo-DP-34044-x-000.zip

https://www.data-panel.eu/media/archive/CODESYS-23-Demo-DP-34044-x-000.zip
https://www.data-panel.eu/media/archive/CODESYS-35-Demo-DP-34044-x-000.zip
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CANopen Manager

▪ Right click on the just inserted "ifmCANbus -> Attach device".

▪ Change manufacturer filter to <all manufacturers>.

▪ Select the device via "CANopen -> CANopenManager -> CANopenManager" and attach
it.

Creator: BD / Version: 1.54

CODESYS PREPARE
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STEP 1

▪ Append a new device to the CANopen_Manager 
(right click -> Append device)

▪ Select the correct module based on the *. eds file 
and close it

STEP 2

▪ Open the configuration of the new device and set 
the node ID.

▪ Then go online, no errors should be displayed in 
CODESYS and the COM LED on the module should be 
permanently green.

Creator: BD / Version: 1.54

CODESYS PREPARE

ADDRESS

▪ xtremeDB CANopen 
modules have the base 
node ID 1 preset

▪ The offset set by means 
of wire jumpers on the 
module is added to the 
base node ID. E.g. If the 
node ID 2 is set in 
CODESYS, the offset 1 
must therefore be 
jumpered on the 
module.

VENDOR ID

For the first series modules, 
the vendor ID was not 
stored in the firmware. In 
this case please either 
update the firmware of the 
module or deactivate the 
check of the vendor ID.

Node ID
Jumper Config1

A (Pin2) -> B (Pin8)

Jumper Config2

A (Pin3) -> B (Pin9)

Jumper Config3

A (Pin4) -> B (Pin10)

Jumper Config4

A (Pin5) -> B (Pin11)

1

2 X

3 X

4 X X

8 X X X

9 X

...

16 X X X X
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Only digital outputs can be parameterized via the global configuration. For all 
other signal types (PWM, PWMi etc.) the individual configuration must be used.

Creator: BD / Version: 1.54

OUTPUT SDO GLOBAL / INDIVIDUAL

There are two possibilities to configure the 
signal pins of the module. The global 
configuration as DI or DO by means of index 
2000:3 or alternatively the individual 
configuration by means of index 2001.

Example of global configuration:
If a 1 is stored in index 2000:3, all signal pins 
are configured as digital outputs (DO). 

Global 
configuration

Individual
Output 
configuration

Individual configuration:

The index 2001:x is used for the individual configuration per signal pin. The configuration for 
port 1, for example, is done via subindex 2001:1. The configuration values are identical to the 
values in index 2000. The parameterization is done in hex code, the first digit is valid for port 
1, pin 2 (signal B) and the second digit for port 1, pin 4 (signal A).

The first digit configures pin 2 (signal B), the second digit the pin 4 (signal A) of 
the respective port. For an individual configuration the index 2000:3 must be 
written with a "0".
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The CANopen I/O image can be used to declare and activate the variables for ports 1 to 4. 

Either the entire integer variable Output_1 can be used for this, alternatively the individual 
bits can also be declared. 

Creator: BD / Version: 1.54

OUTPUT DO - GLOBAL

Go online with the controller and download the program. Force the variable D1OutputB0 to 
"True". Alternatively, store a value in the Dash1Output2 variable.

Port / 
Signal

Value Port / 
Signal

Value

P1A 00 00 00 01 P3A 00 01 00 00

P1B 00 00 00 10 P3B 00 10 00 00

P2A 00 00 01 00 P4A 01 00 00 00

P2B 00 00 10 00 P4B 10 00 00 00

For the global configuration of all outputs as DO (black and white) normally no configuration 
steps in the SDO are necessary. If the entire module is to be configured as DO, it is necessary 
to write the value 11 to index 2000:3. This configures all signal pins as digital output.
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OUTPUT PWMI EXAMPLE PORT 1 A & PORT 1 B -
INDIVIDUAL

To use the module with PWM outputs it is necessary that the signal pins are configured 
individually. For this purpose the global configuration index 2000:3 must be set to 0. 

For each subindex there are two values for configuration. See also SDO global / individual. 
Example: For the configuration of signals 1B and 2AB as PWMi output, index 2001:1 must be 
written with "40" and 2000:2 with "44". Further configuration possibilities can be taken from 
the manual. 

Afterwards the different signals can be activated via the 
CANopen I/O image. For this purpose assign a value between 
0-4000 (0 - 4 A) e.g. Port_1B.

If a value greater than 4000 is sent, the maximum 
value of 4000 is set
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OUTPUT PWMI PORT 1 A KP & KI CONTROL RESPONSE

A PI controller is integrated in the module. The individual PWMi outputs can be 
adjusted in their control behavior. For each pin (4 (A) or 2 (B)) the control behavior can 
be configured individually. 

For a control behavior at port 1 A the index 2002:01 & 2002:02 should be set. Values 
between 0 and 250 are possible ( 0 - 2.5 )

If no value is stored in the respective index, the default value of 100 (1.0) 
applies
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DIAGNOSTICS PORT 1 A & B AMP FEEDBACK

If now e.g. a current value is set on the channel Port_1A (below declared as variable 
D1OutputP1A), the applied current on the channel Port_1A (below declared as variable 
D1OutputP1A_FB) can be read back.

Both channels have the same channel name, the actual values are returned to 
the variable with the higher address and the _FB (feedback) appendix.
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Only digital inputs (PNP or NPN) can be parameterized via the global configuration. 
For all other signal types (analog, ratiometric, etc.) the individual configuration must 
be used.

Creator: BD / Version: 1.54

INPUT SDO GLOBAL / INDIVIDUAL

There are two possibilities to configure the 
signal pins of the module. The global 
configuration as DI by means of index 
2000:3 or alternatively the individual 
configuration by means of index 2001.

Example global configuration:
If a 1 is stored in index 2000:4, all signal 
pins are configured as digital PNP inputs 
(DI). 

Global 
configuration

Individual
Input 
configuration

Individual configuration:

The index 2001:x is used for the individual configuration. E.g. the subindex 2001:5 is used for
the individual configuration of port 5 (A & B). The configuration values are identical to index 
2000. The parameterization is done in hex code, the first digit is valid for port 1 pin 2 (signal B) 
and the second digit for port 1 pin 4 (signal A).

The first digit configures pin 2 (signal B), the second digit pin 4 (signal A) of the 
respective port. For an individual configuration it is important to ensure, that the 
index 2000:4 is set to"0".
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The CANopen I/O image can be used to declare and activate the variables for ports 5-8. 

Either the entire integer variable Input_1 can be used for this, alternatively the 
individual bits can be declared. 

Creator: BD / Version: 1.54

INPUT DI - GLOBAL

Go online with the controller and download the program. Then a sensor can be 
connected to the corresponding port. If this is attenuated, the signal arrives in the 
CANopen I/O image.

Port / Pin Value Port /Pin Value

P5A 00 00 00 01 P7A 00 01 00 00

P5B 00 00 00 10 P7B 00 10 00 00

P6A 00 00 01 00 P8A 01 00 00 00

P6B 00 00 10 00 P8B 10 00 00 00

For the global configuration of all inputs as DI (black and white) normally no 
configuration steps in the SDO are necessary. If the entire module is to be configured as 
DI PNP, it is necessary to write the value "11" to index 2000:4. This configures all signal 
pins as digital input.

P5A
P5B
P6A
P6B
P7A
P7B
P8A
P8B
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INPUT AI 0-10V PORT 5B - INDIVIDUAL

To read in analog signals with the inputs, it is necessary to configure the signal pins 
individually. For this it is necessary that the global configuration index 2000:4 is 
written with a "0". For the configuration of port 5 pin 2 it is necessary to describe the 
index 2001:5 with a "5" or if pin 4 is not to be used "50".

Analog inputs can only be configured for pin 2 (signal B) of each port

Afterwards the input value can be read in the CANopen I/O image.

Should the sensor act outside the measuring range, the respective maximum value is 
returned
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INPUT AI 4-20MA PORT 6B - INDIVIDUAL

To use analog inputs it is necessary to configure the signal pins individually. For this it is 
necessary that the global configuration index 2000:4 is written with a "0". For the 
individual configuration of port 6 pin 2 (signal B) it is necessary to describe the index 
2001:6 with a "3" or if pin 4 is not to be used "30".

Analog inputs can only be configured for pin 2 (signal B) of each port

Afterwards the read back values can be read in the CANopen I/O image.

Should the sensor act outside its range, the 
respective maximum value is returned
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DIAGNOSTICS PORT 1 PIN A & B STATUS / ERROR

In addition to the returned current values, the status of the individual pins can also be 
queried. Index 5001 must be activated for this purpose.

Then the status of the outputs on port 5 and 6 can be queried via the variable 
Status_Output5-6. If an output is activated, the first bit is set. If an error occurs at the 
output, the second bit is set.

If no value is displayed, the index 1805:5 must be written with "C0". This SDO 
takes care of the cyclic data exchange
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DIAGNOSTICS PORT 1 A & B AMP FEEDBACK

For every single signal pin (A or B) the actual current can be read back. To use the 
function, it is necessary to activate the diagnosis via SDO:

For this the index 5003:1 should be written with "8" (default value), then the current 
applied can be read back via the channel

If no value is displayed it is necessary to write "C0" to index 1807 / 1808:5 to 
switch on the cyclic data exchange.

If a constant load is used, the applied current is governed by Ohm's law. If PWMi 
is used, the control behavior of the output can additionally be influenced by the 
proportional and integral component (see p. 16).
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DIAGNOSIS TEMP & VOLTAGE

Further diagnostic data like e.g. the temperature of the module or the bus voltage may 
be read out. For this the index 5002 must be activated.

Afterwards the voltage or the module temperature can be read back in the variable 
VBAT or TEMP. 

The voltage is displayed decimally with a resolution of 0.1 V. 

The temperature has the resolution -100 °F to 300 °F which is displayed in 0-4000 bit 
(factor 10). To display the temperature in , this value must still be converted from 
Fahrenheit to Celsius. E.g. (( 1815 / 10 ) − 100) = 81,5 °F − 32 × 5/9 = 27,5 °C

If no value is displayed, the index 1805:5 must be written with "C0". This SDO 
takes care of the cyclic data exchange
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DIAGNOSIS OUTPUT VOLTAGE P1 / P2 / P3 / P4

In addition, the status of the output voltage supply can be queried. Index 5001 must be 
activated for this purpose.

Subsequently, the status of the individual supply circuits P1 to P4 can be queried in the 
Power variable. 

Bit 0 / 1 = P 4

Bit 2 / 3 = P 3

Bit 4 / 5 = P 2

Bit 6 / 7 = P 1

P4

P3

P2

P1

In the example, only two of the four actuator circuits are supplied with voltage

If no value is displayed, the index 1805:5 must be written with "C0". This SDO 
takes care of the cyclic data exchange.
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Mobile automation, plugged in – done!

Application solutions & products for simple, decentralized and high-quality machine installation


