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POWERED BY MURRELEKTRONIK

Quickstart Guide xDB -5-200

Prerequisites:

- IFM control / display control

- CODESYS 3.5 with necessary packages

- DATA PANEL xtremeDB (DP-34044-5-200) module + accessories
- DC 12/ 24V supply
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Prepare CODESYS

download.

®=  Open CODESYS

@ e

Aktualisieren

Bereits installierte Packages

Depending on the type of controller you are working with, the corresponding packages must
be installed in CODESYS.

The packages for the respective controller are supplied or you can obtain them from
the manufacturer's website or the CODESYS Store. A login may be required for the

= Inthe taskbar at the top via "Tools -> Package Manager... " open the package manager
= Right click on "Install..." and install the corresponding package

= Inthe following example the integration of an ifm display control is described

Sortieren nach | Name M.

Name

& copesys Automati

Version

on Server Connector 1.8.0.0

| ( CODESYS fiir ifm ecomatDisplay_64bit Produkte 1.0.1.0
| 9 CODESYS SoftMotion 4.6.3.0
@ CODESYS Test Manager 4.3.1.0

Installationsdatum

26.09.2020
26.09.2020
26.09.2020
26.09.2020

Update-Info
Freie Version 1,14.0.0 verfii

Freie Version 4.8.0.0 verfiigl

Installieren...

Deinstallieren...

Details...

Updates

Updates suchen

@ Offnen

Em v /Ts <

TestScripts
@ OneDrive

X3 Dieser PC
_JJ) 3D-Objekte
&=/ Bilder
[ Desktop
|| Dokumente
¥ Downloads
J\, Musik
B Videos
s Windows (C:)

< Codesys Installation > Step-3

Organisieren v Neuer Ordner

~

L) Name

& ifm_ecoSys_Lx_64bit_V1.0.1.0.package

- KINGSTON (@)

v o & "Step-3" durchsuchen

Anderungsdatum Typ Grofl

16,07.2020 10:38

Dateiname: | ifm_ecoSys_Lx_64bit_V1.0.1.0.package

CODESYS Package 4

v | Package (*.package) ~

i H o

= Double-click or "Open" to install the package (this may take a moment)

= Ifthe installation was successful, a corresponding message appears

Creator: BD / Version: 1.0
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Install EDS device file

i ]

Open the device repository via "Tools->Device Repository" in the taskbar at the top.
A new device can be installed via the "Install..." button

Double-click on the desired file, alternatively select and open the *.eds file manually.
The device appears in the list of added devices

The permalink below always leads to the latest firmware and *.eds file:
https://drive.google.com/file/d/13cXGUYYZOG3IUt rOJ86NG2fMGVgUtkl/view

S Gerite-Repositon
Speicherort System Repository v Bearbeiten...
{C:\ProgramData\CODESYS\Devices)
Installierte Geratebeschreibunagen
Zeichenfolge fiir eine Volltextsuche I Hersteller | <alle Hersteller> v Installieren... I
Name Herst A Deinstallieren
R () xpBO808-DIO CANopen Data f T
+ - pgot EtherCat
+ . HB} Ethernet Adapter
+ - = EtherNet/IP <
< >
= €% D:\34044-1-200\37000-561-010C.eds
€ Gerat "xDB0B08-DIO CANopen™ im Gerate-Repository installiert
@' Installiere Geratebeschreibung X
Mt <« KINGSTON... » 34044-1-200 v Q) "34044-1-200" durchsuchen
Organisieren ~ Neuer Ordner fz= | o
— N -
=] Dokumente A [ Name Anderungsdatum Typ
& Downloads ~Archiv 24.11.2020 17:30 Dateiord
J Musik | ] 37000-561-010C.eds 23.11.2020 13:09 EDS-Datg
m Videos
‘s Windows (C:)
- KINGSTON (D:)
s KINGSTON (D:)
4.11.2019 v < >
Dateiname: ~ | | Alle unterstatzten Beschreibunt v
Offnen Abbrechen
. .
EE Creator: BD / Version: 1.0 3
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CODESYS project
=  Open CODESYS

= (Create a new project via File -> New

project

= Select the corresponding control via
the library and confirm with OK. The

action may take some time.

J

Kategorien

Vorlagen

+{_J] Bibliotheken
i ecomatDisplay
‘- Projekte

ifm

ecomatDisplay_64...

ifm

ecomatDisplay_64...

| "
ifm
ecomatDisplay_64...
[

ifm
ecomatDisplay_64...

] Al
ifm ifm
ecomatDisplay_64... ecomatDisplay_64... v
Projektvorlage ifm ecomatDisplay_64bit, 10" I
Name | MusterProjektDB |
Oort IE\Users\Admin\Documents v |
o] | o

CAN communication

= Open the "Communication" node and right-click on "CAN -> Attach device".

= Select "ifm" under the manufacturer and append the "ifmCANbus

= Close window

i ]

The controller must be CANopen capable. If you want to work with SAE J1939, you can

find a CODESYS function block for our modules under the following links:
V2.3: https://www.data-panel.eu/media/archive/CODESYS-23-Demo-DP-34044-x-000.zip

V3.5: https://www.data-panel.eu/media/archive/CODESYS-35-Demo-DP-34044-x-000.zip

Gerate v 3 X
=) MusterProjektDB v
= [H Device (ecomatDisplay)
=&l sps-Logik
=} Application
+-{2) Globalvariables
+-2) Textlists
D ifmImagePool
m Bibliotheksverwalter
+-[{] PLC_PRG (PRG)
*#-[E] PLC_PRG_IN_ST (PRG)
= @ Taskkonfiguration
=8 Task (IEC-Tasks)
&) pLc_PrRG
=B VISU_TASK (IEC-Tasks)
@ VisuElems. Visu_Prg
+ VisualizationManager
& visu_Default
= w Communication (Communication)
&% Ethernet (Ethernet)
CAN CAN (CAN)

[ Gerat anhangen

X

Name IifmCANbus

Aktion
(® Gerat anhangen

=0 (O Gerat aktualisieren

|Zewchenfo!ge fiir eine Volltextsuche

| Hersteller | ifim electronic

Name Hersteller Version Beschreibung
= m Feldbusse
= €AN CANbus
@ ifmelectronic  1.0.0.0  Needed for all fieldbus which communicate over the CANBU
< >
Nach Kategorien gruppieren [_] Alle Versionen anzeigen (nur fiir Experten) [ ] Veraltete Versionen anzeigen
[  Name:ifmCANbus ~
Hersteller: ifm electronic
Kategorien:
Version: 1.0.0.0 -
Bestellnummer: ??7? -
Beschreibung: Needed for all fieldbus which communicate over the CANBus, v ==Y
Anhdngen des ausgewahlten Gerits als letztes "Kind" von
CAN
€©  (Siekonnen einen anderen Zielgeratknoten im Navigator auswahlen, solange dieses Fenster gedffnetist)
Gerat anhangen SchlieBen |

Creator: BD / Version: 1.0
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CANopen Manager
= Right click on the just inserted "ifmCANbus -> Attach device".
= Change manufacturer filter to <all manufacturers>.
= Select the device via "CANopen -> CANopenManager -> CANopenManager" and attach
it.
[ Gerit anhangen X
Name lCANopen_Manager
Aktion
(® Gerat anhangen () Gerat einfiigen srat enstecken (O) Gerat aktualisieren
)Zeichenfolge fiir eine Volltextsuche ] Hersteller | <alle Hersteller> v
Name Hersteller Version Beschreibung
= 13 Feldbusse
= €ifl CANopen
= - &ift CANopenManager
[ [canopen_Manager 35 - Smart Software Solutions GmbH ~ 3.5.16.0  CANopen Manager
Eﬁ CANopen_Manager_SIL2 35 - Smart Software Solutions GmbH 3.5.16.0 CANopen_Manager_SIL2
Eﬂ CANopen_Manager_SoftMotion 35 - Smart Software Solutions GmbH 3.5.16.0 CANopen Manager SoftMotion
+ - €ifl Lokales Gerat
+ - SAF 11939
Nach Kategorien gruppieren |:| Alle Versionen anzeigen (nur fir Experten) |:| Veraltete Versionen anzeigen
jfﬂ Name: CANopen_Manager A
Hersteller: 35 - Smart Software Solutions GmbH
Kategorien: CANopenManager
Version: 3.5.16.0 =
Bestellnummer: =
Beschreibung: CANopen Manager v 5
Anhédngen des ausgewahlten Gerits als letztes "Kind" von
ifmCANbus
€  (Siekonnen einen anderen Zielgeratknotenim Navigator auswahlen, solange dieses Fenster gedffnetist)
. .
N Creator: BD / Version: 1.0 5
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STEP 1

close it

STEP 2

node ID.

= Append a new device to the CANopen_Manager (right
click -> Append device)

=  Select the correct module based on the *.eds file and

= Open the configuration of the new device and set the

*= Then go online, no errors should be displayed in
CODESYS and the COM LED on the module should be
permanently green.

'® ecomatDisplay1.project* - CODESYS

Datei Bearbeiten Ansicht  Projekt

EFE & v

Erstellen  Online  Debu

o f BB X (MMM A

ecomatDisplay 1
= - [H Device [Verbunden] (ecomatDisplay)
= (80 sps-Logk
= £ Application [run]
+ () Globalvariables
+ [Testproy J
+ 1) Textlists
(] ifmimagePool
) sibiotheksverwalter
+ [#] PLC_PRG (PRG)
#-[B] PLC_PRG_IN_ST (PRG)
+ @ Taskkonfiguration
+ VisualizationManager
@ Visu_Default
= @ Communication (Communication)
&% Ethernet (Ethernet)
= ¥3¢AN CAN (CAN)
= 5 [{@ ifmCANbuS (fmCANbus)
= 5 [ cAnopen_Manager (CANopen_Manager)
<5 @ our (cANopen DPBlock)

v X

bmatDisplay 1
B Device [Verbunden] (ecomatDisplay)
£ sps-Logk
= £ Application [run]
+ 1) Globalvariables
= 2 Testproject
[E TesT ero)
+ D Textlists
{=]] ifmImagePool
ﬂ Bibliotheksverwalter
+ [@] PLC_PRG (PRG)
#-[B) PLC_PRG_IN_ST (PRG)
+ (B8 Taskkonfiguration
+ @ VisualizationManager
@ visu_Defauit
< @ Communication (Communication)
)&% Ethernet (Ethernet)
= £3CAN CAN (CAN)
=3 ifmCANbus (fmCANbus)
=-6 mCANopm_Nanaqer (CANopen_Manager)

4

@ our x|[[5) TEST |

Allgemein <
9 Allgemein

Node-ID |11 =

PDOs

SDOs [] Experteneinstellungen

SYNC-Erzeugung aktivieren
Log
Uberwachung
CANopen E/A-Abbild

Emergency (EMCY) ———|
CANopen IEC-Objekie Prifungen beim Start

Status

Information

<

Uberwachungsliste 1

Ausdruck

Allgemein

Node-ID |11

[] Experteneinstellungen

SYNC-Erzeugung aktivieren

CANopen

|- Uberwachung

|- Emergency (EMCY) —

I TIME

4 Prifungen beim Start

[] Hersteller-ID

[] Produktnummer

[] Revisionsnummer

Jumper Configl
Node ID
A (Pin2) -> B (Pin8)

Jumper Config2
A (Pin3) -> B (Pin9)

Jumper Config3

Jumper Configd
A (Ping) -> B (Pin10) A (Pin5) -> B (Pin11)

Creator: BD / Version: 1.0

0 ADDRESS
=  The module has the base
node ID 1 preset

= The offset set by means
of wire jumpers on the
module is added to the
base node ID. If the node
ID 2 is set in CODESYS,
the offset 1 must
therefore be jumpered
on the module.

@ venoor 0

For the first series modules,
the vendor ID was not stored
in the firmware. In this case
please either update the
firmware of the module or
deactivate the check of the
vendor ID.
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OUTPUT DO - GLOBAL

This module does not need to be configured, all outputs are designed as DO output

o This module does not need to be configured

The CANopen I/0 image can be used to declare and activate the variables for ports 1 to 4.

Either the entire integer variable Output_1 can be used for this, alternatively the individual bits can
also be declared.

Find Filter Show all v ok AddFBforlO
Variable Mapping  Channel Address Type Current Value
=" Output_1 %QB0 USINT

"% D5_DO_P1A »  BW %QX0.0  BOOL [
"$ D5_DO_P1B ® Bit1 %QX0. 1 BOOL
" Bit2 %QX0. 2 BOOL
"o Bit3 %QX0.3 BOOL
"o Bitd %QX0.4 BOOL
" BtS %QX0.5 BOOL
"o Bit6 %QX0.6 BOOL
"» Bit7 %QX0.7 BOOL
+ "o Outout 2 %081 USINT

Go online with the controller and download the program. Force the variable D10utputB0 to "True".
Alternatively, store a value in the Dash1Output2 variable.

Output Ports

Hi) g\\‘ Output B (4A)
. “”H Ground (B)

Ground (B)
Output A (4A)

Slgnal Slgnal

00 00 00 01 00 01 00 00
P1B 000000 10 P3B 00 10 00 00
P2A 00 00 01 00 P4A 01 00 00 00
P2B 000010010 PAB 10 00 00 00

Em Creator: BD / Version: 1.0 7
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OUTPUT DO PORT 10A

With the outputs 1A and 3A actuators up to a current of 10A can be supplied. For this
purpose, a value between 0-100 (0 - 10.0 A in 100 mA steps) can be stored in the index
2004:1. If, for example, "40" is stored, the output current is set to max. 4.0 A.

PR =Tal R P o ] PP e M 4 TS Er= L1 =

Element aus dem Objektverzeichnis auswihlen >
Index:Subindesx Mame Zugriffstyp Datentyp Standardwert
1651017 16%00 Producer Heartheat Time R LINT 16700
+ - 16#1400 Receive PDO Communication Parameter 1
+-- 16#1804 Transmit PDO Communication Parameter 5
+- 1651805 Transmit PDO Communication Parameter o
+- 1671800 Transmit PDO Communication Parameter 7
- 16#1807 Transmit PDO Communication Parameter 8
+- 1671808 Transmit PDO Communication Parameter 9
+- 16751809 Transmit PDO Communication Parameter 10
+ - 162000 Module Global Configuration
= 162004 Module 104 Limit Configuration
v 16#00 Highest sub-index supported R LISIMT 16#2
(16401 Port_1A R USIMT
(16402 Port_3A R USIMT
+- 1675000 Response Message
+- 1675001 Status Message F1
+ - 165002 Status Message F2 v
< il - . N N
MName Part_1A |
Index 16%2004 = Bitlange |8 =
Subindex 1521 L wert 1620 |
Abbrechen

EN Creator: BD / Version: 1.0 8
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DIAGNOSIS PORT 1A & B AMP FEEDBACK

For each individual signal pin (A or B), the current currently present can be read back.

To use the function, it is necessary to activate the diagnosis via SDO To do this, write "10" to index
5003:0 (default value), then the current present can be read back via the channel.

= 2= 116=01 5et and enable COB-IC 12=000 32 E El
57 1642000 16503 Output_Mode 16200 B O O
58 1622001:16=01 OUTMODE_1 16210 8 [l 0
52 16#2001:16503  OUTMODE_3 1611 8 O O
&0 1622004 16201 Port_1A 16255 B |l O
| & 16:#5003: 16200 Highest sub-index supported 16210 B h 0

0 If no value is displayed, the index 1807 / 1808 :5 must be written with "C0" to
switch on the cyclic exchange of the signals.

@ If a constant load is used, the applied current is governed by Ohm's law. When using
PWMIi, the control behavior of the output can additionally be influenced by the
proportional and integral component (see p. 12).

EN Creator: BD / Version: 1.0 9
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If now e.g. the channel (Below declared as variable D5 _DO_P1A) is switched on, the
applied current on the channel (Below declared as variable D5_DO_P1A FB) can
be read back.

If no value is displayed, the index 1807 / 1808 :5 must be written with "C0" to
switch on the cyclic exchange of the signals.

=" Output_1 %QB58 USINT
| “# D5_DO_P1A i Bit0 |  =e0xs58.0 BOOL I5410 |
) Bit1 %QX58.1  BOOL
T Bit2 %QX58.2  BOOL
i Bit3 %QX58.3  BOOL
" Bit4 %QX58.4  BOOL
T Bit5 %QX58.5  BOOL
i Bits %QX58.6  BOOL
" Bit7 %QX58.7  BOOL
+- g Output_2 %0QB53 USINT
+ A di-ds %%IB200 USINT
+ Ay d3-dis %IB201 USINT
+ Active_Fault_Code %eIB202 LISINT
+ 4 Configuration_ID %LIB203 USINT
+ Ay d1-d3_Message 2%IB204 USINT
+ A d9-d16_Message %IB205 LISINT
+ Ay Status_Output1-2 %IB206 USINT
+ Ay Status_Output3-4 %IB207 USINT
+ A Status_Output5-6 %1520 USINT
+ Ay Status_Output7-8 %IB209 USINT
+ 4 Power 2%IB210 USINT
e ] Save_Counter %elB211 USINT
+ Ay VBAT %IV 106 UINT
+ A TEMP %IW 107 UINT
+ CNFG1 LIV 108 UINT
+ A CNFG2 IV 109 UINT
+ ’f D5_DO_P1A_FB @ Port_1A | %B220 USINT 5390
+ Port 1B %IB221 USINT

EN Creator: BD / Version: 1.0 10
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DIAGNOSIS PORT 1 PIN A & B STATUS / FEHLER

The status of the individual outputs can be queried by activating index 5001. Subsequently,
the status of the outputs on port 1 and 2 can be queried via the variable Status_Output 1-2.
If an output is activated, the first bit (DP_DO_P1A_OK) is set. If an error occurs at the
output, the second bit (D5_DO_P1A_FLT) is set.

If no value is displayed, the index 1805:5 must be written with "C0". This SDO takes
care of the cyclic exchange of the data.

16#1809: 16501 Set and enable COB-ID 16500000 2EA 32 |:|
16#5001:16%00  Highest sub-ndex suppo... 16%8 3 D_I
: imer S0l 15 =1
e — o " Valals - M1 Al Prsmie e e e | N | PRI Y L N TP - S-S I
=-"ip Output_1 %QB53 USINT
"% D5_DO_P1A @ BitD %Qx58.0 ool RGN
g Bit1 %QKX58.1  BOOL
g Bit2 %QKX58.2  BOOL
T Bit3 %0X58.3  BOOL
] Bit4 %0QX58.4  BOOL
" Bit5 %QX58.5  BOOL
" BitS %QX58.56  BOOL
T Bit7 %Qx58.7 BooL (RS
+- i Output_2 %QB53 USINT
+ 4 di-da %IB200 USINT
+ A d9-d1s %IB201 USINT
+o Active_Fault_Code %ReIBE202 LISINT
+o M Configuration_ID %eIB203 USINT
+ My d1-ds_Message 2%IE204 USINT
+ 4 d9-d16_Message %LIB205 LISINT
=- 4 Status_Output1-2 %IB206 USINT
*% D5_DO_P1A_OK BitD %x206.0 BooL | RGHE
4% D5_DO_P1A_FLT Bit1 %IX206.1  BOOL
B Bit2 %I¥206.2  BOOL
P Bit3 %I¥206.3  BOOL
*p Bit4 °%IX206.4  BOOL
P Bit5 °%IX206.5  BOOL
P Bits %IX206.6  BOOL
L Bit7 %IX206.7  BOCL FALSE

EN Ersteller: BD / Version: 1.0 11
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TEMP.

Further diagnostic data like e.g. the temperature of the module or the bus voltage may be
read out. For this the index 5002 should be activated.

Afterwards the voltage or the module temperature can be read back in the variable VBAT or

The voltage is displayed decimally with a resolution of 0.1 V.

The temperature has the resolution -100 °F to 300 °F which is displayed in 0-4000 bit (factor
10). For the display of the temperature in °C, this value must still be converted from
Fahrenheit to Celsius. e.g. (( 1815 /10 ) - 100) =81.5 °F-32 x 5/9 = 27.5 °C

If no value is displayed, the index 1806:5 must be written with "C0". This SDO takes

care of the cyclic exchange of the data

37 16#5002: 1600 Highest sub-index supported 16#5 8 I
38 16#1806: 16505 Event Timer 16#C0 16
% Power %IB30 USINT 20
L Save Counter %IB31 USINT 0

+ |9 DSVBAT ” VBAT %IW41 UINT 241
+ I"? DSTemp F TEMP %IW42 UINT 1815
L CNFG1 %LIW43 UINT 3

+ 4 CNFG2 %IW44 UINT A

L Port_1A %IW4S UINT 0

+- Port_1B %LIW46 UINT 0

+ Y Port_2A %IW47 UINT 0

+ Port_28 %I 48 UINT 0

+- Port_3A %IW49 UINT 0

+ Y Port_38 %IWS0 UINT 0

+ Port_4A %IWS1 UINT 0

EN Creator: BD / Version: 1.0
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DIAGNOSIS AUSGANGSSPANNUNG P1

the variable Power.

Bit1/2=P1

In addition, the status of the output voltage supply can be queried. Index 5001 must be
activated for this purpose. Subsequently, the status of the supply circuit P1 can be queried in

0 If no value is displayed, the index 1805:5 must be written with "C0". This SDO takes

care of the cyclic exchange of the signals.

0 The -5 has only one output power supply P1

34 16#1809: 16501 Set and enable COB-ID 16#000002EA 3.2 |:|
35 16%5001: 1600 Highest sub-index suppo... 16#%8 g8 | I
EVENL 1imer o=y e F
e — o " Y aTalel - M1 Al Prsmie e e e | N | PRI Y L N TP - S-S I
— — —
“» D3Power ’ Power %IB30 USINT 20
» &0 %IX80.0 BOOL RUE
» Bit] %Ix30.1 BOOL N
“» Bit2 %IN30.2 BOOL
“» Bit3 %Ix30.3 BOOL
“ Bit4 %IX30.4 BOOL
“ BitS %IX30.5 BOOL
“» Bit6 %IX80.6
— — —
“ Save_Counter %831 USINT 0
“» D3veaT 9 VBAT %RIW41 UINT 241
“ D3Temp » TEMP %IW42 UINT 1815
L CNFG1 %IW43 UINT 3

Creator: BD / Version: 1.0 13
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Application solutions & products for simple, decentralized and high-quality machine installation

Mobile automation, plugged in - what
else!
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